<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":2,"applicationTime":475,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-83277604-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>PirateCrew.com  -  Part 2: Redemption</title>
<meta content='PirateCrew.com  -  Part 2: Redemption' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-42736c1a7eb2a694d80bae23270ea1b0c5d5da44d33cc12c90aec89380ed21f5.css" />

<script src="https://cdn.rivals.com/production/assets/application-1192834571c64be74f40c174e62f4a16bd5be09f451ac0b083467411d00857c8.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="zPSFWCsC6eWLybyuffYZ6+4L/Yn/4CIXkaWpgIHWPVek6UrLHKKdo36uX2JC0cNXrzTY98G/BPCbdyOjslZg7A==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://setonhall.rivals.com/news/part-2-redemption' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/vd0jusbu2yw7zzb01try' property='og:image'>
<meta content='  This five part series will chronicle the past four years at the Hall.' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-03-22 11:24:29 -0500' property='article:published_time'>
<meta content='2018-03-22 17:17:03 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "setonhall.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='setonhall contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .setonhall #programming > h1 {
      background-color: #bcbcbc !important; } }
  .setonhall > header .notification-link .count-container {
    background-color: #bcbcbc !important; }
  .setonhall > header .wrapper-container {
    background-color: #bcbcbc !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .setonhall > header .wrapper-container {
        border-bottom: 5px solid #1d1dff !important; } }
  .setonhall > header .invalid-email-banner {
    background-color: #bcbcbc;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .setonhall > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .setonhall > header .invalid-email-banner a:hover {
      color: #1d1dff; }
  @media screen and (max-width: 767px) {
    .setonhall > header .mobile-header {
      background-color: #1d1dff !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .setonhall > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .setonhall > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .setonhall > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .setonhall > header .nav-row > ul,
    .setonhall > header .third-nav {
      background-color: white !important; }
    .setonhall > header .dropdown-toggle > i.fa {
      color: #bcbcbc !important; } }
  .setonhall > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #bcbcbc; }
  
  .site-primary-font-color {
    color: #bcbcbc; }
  
  .site-primary-background-color {
    background-color: #bcbcbc; }
  
  .site-secondary-font-color {
    color: #1d1dff; }
  
  .site-secondary-background-color {
    background-color: #1d1dff; }
  
  :root {
    --outbrain-primary-color: #bcbcbc;
    --outbrain-secondary-color: #1d1dff; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="Seton Hall" class="school-header" href="//setonhall.rivals.com"><span class='header-text'>
        PirateCrew.com
      </span>
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//setonhall.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;setonhall&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//setonhall.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;setonhall&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733142,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Part 2: Redemption"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='@Rivals' name='twitter:site'>
<meta content='Part 2: Redemption' name='twitter:title'>
<meta content='  This five part series will chronicle the past four years at the Hall.' name='twitter:description'>
<meta content='https://res-4.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/vd0jusbu2yw7zzb01try' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1906366,"title":"Part 1: The Roller Coaster","slug":"the-roller-coaster-part-1","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-21T10:56:09.145-05:00","summary":"  This five part series will chronicle the past four years at Seton Hall","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/the-roller-coaster-part-1","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1905746,"title":"Thoughts on the 2017/18 season and the future of Pirate basketball","slug":"thoughts-on-the-season-and-the-future-of-pirate-basketball","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-19T15:06:32.079-05:00","summary":" steelersrule125 opines on the past and the future of Pirate baskeball","deleted":false,"author_name":"Adam Baliatico","author_title":"Trove contributor","permalink":"https://setonhall.rivals.com/news/thoughts-on-the-season-and-the-future-of-pirate-basketball","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1900635,"title":"Two is better than one","slug":"two-is-better-than-one-4","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-04T15:49:03.209-06:00","summary":"2G guard Deeno the better choice. ","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/two-is-better-than-one-4","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1896250,"title":"Seton Hall Exorcises Their (Blue) Demons","slug":"seton-hall-exorcises-their-blue-demons","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-02-19T18:38:51.684-06:00","summary":" Pirates Edge DePaul at the Rock","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/seton-hall-exorcises-their-blue-demons","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1890904,"title":"John Leahy: Seton Hall Now \u0026 Then","slug":"john-leahy-seton-hall-now-then","kind":"free","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-02-04T07:46:49.643-06:00","summary":"The Trove talks to former Pirate John Leahy","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/john-leahy-seton-hall-now-then","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1890449,"title":"Khadeen Carrington Makes a &#x0027;Point&#x0027;","slug":"khadeen-carrington-makes-a-point-","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-02-02T10:16:52.693-06:00","summary":"Observations from the Rock","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/khadeen-carrington-makes-a-point-","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1888422,"title":"PJ Talks to the Trove. \"It should have been Jerry, Terry or Arturas.\" ","slug":"pj-talks-to-the-trove","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-01-27T09:37:55.693-06:00","summary":"The Trove got a chance to talk to PJ Carlesimo before the Georgetown game.","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/pj-talks-to-the-trove","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1886388,"title":"Big Mac Gives Seton Hall Indigestion","slug":"big-mac-gives-seton-hall-indigestion","kind":"free","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-01-21T09:24:54.529-06:00","summary":"Xavier&#x0027;s JP Macura puts the Musketeers on his back","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/big-mac-gives-seton-hall-indigestion","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1884864,"title":"The Art of playing basketball at the Hall","slug":"the-art-of-playing-basketball-at-seton-hall","kind":"premium","site_id":123,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-01-16T15:51:43.453-06:00","summary":"Karnisovas looks back to his time at the Hall","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/the-art-of-playing-basketball-at-seton-hall","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1884177,"title":"Georgetown Has Ish-ues","slug":"georgetown-ish-uuuus","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-01-14T13:31:33.884-06:00","summary":"Sanogo does it without the glaring stats","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/georgetown-ish-uuuus","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1881614,"title":"Midterms","slug":"midterms-5","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-01-06T09:38:56.404-06:00","summary":"Player grades as Big East play begins","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/midterms-5","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1880028,"title":"Pirates quell the Storm","slug":"pirates-quiet-the-storm","kind":"premium","site_id":123,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-01-01T13:45:56.435-06:00","summary":" Toughing one out","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/pirates-quiet-the-storm","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1879285,"title":"Seton Hall &#x0027;Rocks&#x0027; Creighton","slug":"the-hall-rocks-creighton","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2017-12-29T12:08:20.770-06:00","summary":"9800 plus help the Hall overcome a 13 point 2nd half deficit","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/the-hall-rocks-creighton","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1877989,"title":"Pirates &#x0027;maul&#x0027; Manhattan","slug":"pirates-maul-manhattan","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2017-12-24T08:50:03.672-06:00","summary":"SHU fights off the Jaspers","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/pirates-maul-manhattan","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1877237,"title":"Deeno dominates","slug":"carrington-breaks-out","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2017-12-21T11:18:24.143-06:00","summary":"Carrington rocks the Rock","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/carrington-breaks-out","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1874829,"title":"St Peter&#x0027;s post game, behind the mike","slug":"st-peter-s-post-game-behind-the-mike","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2017-12-15T17:56:52.265-06:00","summary":"  Post game quotes.","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/st-peter-s-post-game-behind-the-mike","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1873843,"title":"Walsh Gymnasium, a trip down memory lane","slug":"walsh-gymnasium-a-special-place-to-play","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2017-12-13T08:47:14.703-06:00","summary":"  Musing from Walsh","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/walsh-gymnasium-a-special-place-to-play","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1872848,"title":"SHU/VCU post game interviews","slug":"post-game-interviews-75","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2017-12-10T12:51:32.127-06:00","summary":"Willard, Rodriquez and Delgado talk to the press.","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/post-game-interviews-75","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1872800,"title":"Pirate&#x0027;s balance too much for the Rams","slug":"pirate-balance-dominates-the-rams","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2017-12-10T09:41:19.642-06:00","summary":" Sights and sounds on a Saturday afternoon from the Rock","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/pirate-balance-dominates-the-rams","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1869825,"title":"Powell \u0026 Rodriquez help the Hall &#x0027;shoot&#x0027; down the Red Raiders","slug":"powell-helps-the-hall-shoot-down-the-red-raiders","kind":"premium","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2017-12-01T10:54:49.162-06:00","summary":"The Pirates lower the boom on Texas Tech ","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/powell-helps-the-hall-shoot-down-the-red-raiders","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1867582,"title":"The Hall rebounds in the consolation round of the NIT","slug":"the-hall-rebounds-in-the-consolation-finals-of-the-nit","kind":"free","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2017-11-25T13:27:36.456-06:00","summary":"Desi and the Hall down the Commandeers ","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/the-hall-rebounds-in-the-consolation-finals-of-the-nit","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]},{"id":1866301,"title":"Young Pirates more than sharing the load","slug":"the-young-players-more-than-carrying-their-share","kind":"free","site_id":123,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2017-11-21T13:06:53.452-06:00","summary":"Part 2, player breakdown after the NJIT blowout ","deleted":false,"author_name":"Dan Gioseffi","author_title":"Trove Correspondent ","permalink":"https://setonhall.rivals.com/news/the-young-players-more-than-carrying-their-share","site_name":"PirateCrew.com","type":"Content","programming":[],"associated_links":[]}], nil, 123, nil, true); subdomain = &#x0027;setonhall&#x0027;; aolPlayerId = &#x0027;58e686759efa8936610b8215&#x0027;; aolCompanyId = &#x0027;58e68374c7480e728bcc385f&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #bcbcbc'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://setonhall.rivals.com/news/part-2-redemption' background-color='#bcbcbc' base-api-url='https://setonhall.forums.rivals.com/' homepage='false' message-board-url='setonhall.forums.rivals.com' pub-ad='null' size='size' space-id='2022733142' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://setonhall.rivals.com/news/part-2-redemption/printable' site-name='PirateCrew.com'></rv-share-links>
</div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-03-22 11:24:29 -0500') }}</span>
<span class='article-header-sport'>basketball</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1906774/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Part 2: Redemption</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<span>
<span class='title-sm'>
Dan Gioseffi
&bull;
</span>
<span class='type-sm'>PirateCrew.com</span>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Trove Correspondent </span>
</span>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='st__content-block st__content-block--text article-text'>
<p> This five part series will chronicle the past four years and will touch on the individual seasons following the commitments of Isaiah Whitehead and his fellow class of 2018 teammates.</p><p>At the conclusion of each season I will attach a grade for head coach Kevin Willard.</p><p>2016</p><p>Relevant Kenpom stats at the conclusion of the season</p><p>#29 <a href="https://kenpom.com/team.php?team=Seton+Hall&amp;y=2016">Seton Hall</a> (6 seed) <a href="https://kenpom.com/conf.php?c=BE&amp;y=2016">BE</a> 25-9 12-6</p><p>Conference-only offense 6th</p><p>Conference-only defense 2nd</p><p>3rd place league finish</p><p>Tournament champions</p><p>Lost in first round of the NCAA to Gonzaga<a href="https://kenpom.com/box.php?g=5866&amp;y=2016">, 68-52</a></p><p>Final RPI</p><p># 23</p><p>After the disastrous ending to the 2015 season questions abound regarding the job status of Kevin Willard. Would he be fired? Would he leave for another job? Or would he be asked to return for a 6th year?</p><p>Shortly after the conclusion of the season word leaked that Willard through his associates got word out to Holy Cross that he might be interested in their vacant head coaching position. Willard as one would expect denied the rumor but there was much evidence behind the scenes to the contrary. </p><p>Regardless, the point became moot shortly thereafter when Willard and Seton Hall AD Pat Lyons had a sit down to discuss the programs future. At that meeting, since confirmed by Willard, he told his AD that he was all in with his current group believing that the prior season was a misstep and given one more chance he would reach a level of success that Seton Hall has not seen in quite some time.</p><p>He told that to Lyons knowing that one more year of poor results would lead to his dismissal. </p><p>Lyons, who was Willard's AD at Iona where Willard cut his teeth as a D1 head coach heard what he wanted to hear and did not hesitate in giving Willard the extra season he so badly wanted. </p><p>Music to the ears of many at the Hall who came to like and respect Willard. But not so with the fan base disappointed with the coaches results to date, which included just 1 NIT trip, an overall record of 82-80, 30-60 in conference, and a best 7th place finish in conference. Numbers that would easily justify any high major D1 coach being fired.</p><p>Fortunately it would get better for the Hall, much, much better. But before that happened it got worse. </p><p>Leading scorer junior Sterling Gibbs, despite informing the school he would not leave as a graduate transfers did just that a couple of weeks later departing for the University of Connecticut to play for then coach Kevin Ollie. The news at the time seemed to be another nail in the coffin for Willard. But to his credit the Seton Hall coach rebounded well accepting a grad transfer in his own right, Derrick Gordon. </p><p>At the time losing Gibbs and gaining the 6-3 guard seemed like a major blow to the Hall, but as it turned out nothing could have been further from the truth. </p><p>Gordon was not the on court talent that Gibbs was, but he fortified a questionable locker room with his strong leadership skills and never say die attitude. Something that was sorely missing one year prior.</p><p>The fact that Gordon was also a lock down defender greatly helped as noted by the above Kenpom stats rating the Pirates as the second most efficient defensive team in the league.</p><p>The parts were beginning to fit, especially with a now set rotation featuring star recruit Isaiah Whitehead joining his good friend Khadeen Carrington in the starting backcourt, fortified by Desi Rodriquez now at his more natural SF spot, Ish Sanogo back in the picture as the staring 4 and the rock solid Angel Delgado manning the middle. </p><p>What seemed so desperate just just 8 months ago now seemed to take a polar opposite direction. There was hope and it was legitimate.</p><p>As they did in 2015 Seton Hall came out of the gate on fire. To the tune of 12-2, 2-0 in conference, making Pat Lyon look like a genius for taking a final chance on his embattled coach. The hot seat was hot no longer.</p><p>But then as it did the previous season the Hall hit a major bump in the road losing 4 of their next 5 games and visions of the 2015 collapse danced in the heads of all Pirate fans. </p><p>Willard to his credit stood firm confidently predicting that this team was different and what happened the year past would not happen again. </p><p>Coaches speak from a man desperately trying to hold on to his job? Many thought so but as the remainder of the regular season played out his words were prophetic. The Pirates concluded the season winning 9 of their last 11 games finishing 3rd in the league with a 12-6 mark. </p><p>Great numbers, but the best was yet to come.</p><p>The Big East tournament followed the Hall's blazing end to the regular season and the hope was that the Pirate would make a good showing and fortify their first invite to the NCAA Tournament since the days of Louis Orr. </p><p>Box checked. The Hall did that and so much more. In a three day span Seton Hall beat Creighton and then two top five teams in Xavier and Nova, the latter in a nationally televised game that rocked the Garden to its rafters. </p><p>Willard had made good his promise to Lyons taking the Hall to heights that even he did not imagine on his way to being named conference Co-COY with Villanova's Jay Wright. </p><p>The Hall was back.</p><p>Unfortunately there would be no more highlights as Seton Hall physically and more importantly mentally exhausted had to play a vastly under-seeded Gonzaga team in their part of the country 4 days later falling by the score of 68-52. But that did not in any way tarnish what these Pirates led by Isaiah Whitehead did down the stretch. </p><p>Seton Hall was indeed back on the basketball map and the decision made so many months prior in the office of Pat Lyons pay dividends that even he could not have imagined.</p><p>Kevin Willard's 2016 season grade: A </p>
</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://setonhall.rivals.com/news/part-2-redemption/printable' site-name='PirateCrew.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":false,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Rivals","football":false,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Schedule","football":false,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":123,"legacy_id":959,"name":"PirateCrew.com","friendly_name":"Seton Hall","annual_discount":null,"subdomain":"setonhall","primary_color":"bcbcbc","secondary_color":"1d1dff","font_color":"ffffff","short_name":"setonhall","maple_ncaaf_team_id":null,"maple_ncaaf_endpoint":null,"maple_ncaab_team_id":508,"maple_ncaab_endpoint":"ncaab/teams/sao","maple_college_id":637,"google_analytics_id":"UA-83277604-1"}' twitter-feed='{"id":123,"site_id":123,"handle":null,"list_name":null,"created_at":"2016-02-01T12:25:22.645-06:00","updated_at":"2016-02-01T12:25:22.645-06:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://setonhall.rivals.com/news/part-2-redemption/printable' site-name='PirateCrew.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733142', 'https://setonhall.rivals.com/news/part-2-redemption');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Part 2: Redemption";
  _sf_async_config.sections = 'content,content-basketball,content-basketball-free,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://setonhall.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733142",
    c7: "https://setonhall.rivals.com/news/part-2-redemption"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fsetonhall.rivals.com%2Fnews%2Fpart-2-redemption&c5=2022733142&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
